Difference between revisions of "WxNviz"

From GRASS-Wiki
Jump to: navigation, search
m (Missing features)
(Known issues)
Line 58: Line 58:
 
* Tick marks and coordinate values to x,y,z axis when drawing fringe
 
* Tick marks and coordinate values to x,y,z axis when drawing fringe
  
== Known issues ==
+
<strike></strike>
  
# List of [http://trac.osgeo.org/grass/query?status=assigned&status=new&status=reopened&order=priority&col=id&col=summary&col=status&col=owner&col=type&col=priority&col=milestone&keywords=~wxNviz open] and [http://trac.osgeo.org/grass/query?status=assigned&status=closed&order=priority&col=id&col=summary&col=status&col=owner&col=type&col=priority&col=milestone&keywords=~wxNviz closed] tickets
+
== Known issues  ==
# Adding vector data crashes wxGUI on Mac
+
 
# Viewing height sometimes sets to 1 after switching to 2D and back to 3D View (or with the simultaneous 2D view - very nice feature) and even after View is reset, it keeps getting back at 1 each time the slider is touched
+
#List of [http://trac.osgeo.org/grass/query?status=assigned&status=new&status=reopened&order=priority&col=id&col=summary&col=status&col=owner&col=type&col=priority&col=milestone&keywords=~wxNviz open] and [http://trac.osgeo.org/grass/query?status=assigned&status=closed&order=priority&col=id&col=summary&col=status&col=owner&col=type&col=priority&col=milestone&keywords=~wxNviz closed] tickets  
#:Hopefully fixed in {{rev|46208}}
+
#<strike>Adding vector data crashes wxGUI on Mac</strike>
# Isosurfaces tested with Nags Head time series data (I will provide link) don't seem to be working, after setting 3D region and adding 3D raster nothing gets drawn, when moving the related DEM around only line rectangle shows instead of a box.
+
#<strike>Viewing height sometimes sets to 1 after switching to 2D and back to 3D View (or with the simultaneous 2D view - very nice feature) and even after View is reset, it keeps getting back at 1 each time the slider is touched</strike>
# Adding draw, draw current and clear button may be useful
+
#:Fixed in {{rev|46208}}  
# Thematic mapping is available in GRASS 7 only
+
#Isosurfaces tested with Nags Head time series data (I will provide link) don't seem to be working, after setting 3D region and adding 3D raster nothing gets drawn, when moving the related DEM around only line rectangle shows instead of a box.  
# Display region in 3D does not change accordingly to display region in 2D in version <= 6.5
+
#Adding draw, draw current and clear button may be useful  
# Appearance:
+
#Thematic mapping is available in GRASS 7 only  
## scale bar does not work with my terrestrial lidar x,y data (but it worked in grass7 with different data)
+
#Display region in 3D does not change accordingly to display region in 2D in version &lt;= 6.5  
## add legend > OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D but when I clicked delete scalebar (which was not drawn), my surface disapeared but the legend showed up along with white and black background (which I assume was supposed to be transparent, because when I moved the legend the surface was under it - we already discussed this, it may be my problem, because it works for Michael).
+
#Appearance:  
# General
+
##&nbsp;I&nbsp;need to click View tab to get the arrow draw, same for the scale bar  
## when I go from 3D view to 2D and then back to 3D I lose most of my settings (viewing position, zexag, fringe size etc. - this would be OK if I could get a warning and question whether I want to save my 3D viewing state before switching)
+
##add legend &gt; OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D but when I clicked delete scalebar (which was not drawn), my surface disapeared but the legend showed up along with white and black background (which I assume was supposed to be transparent, because when I moved the legend the surface was under it - we already discussed this, it may be my problem, because it works for Michael).  
## similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default
+
#General  
# Volumes:
+
##when I go from 3D view to 2D and then back to 3D I lose most of my settings (viewing position, zexag, fringe size etc. - this would be OK if I could get a warning and question whether I want to save my 3D viewing state before switching)  
## change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS starts with the default 3D region settings volumes do not work because there is just one level.
+
##similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default  
## isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due my resolution being 0.3m, when I change it to 1m I get at least some limited slicing
+
#Volumes:  
### this may be in ogsf becuase slices in nviz do not work with this data either
+
##change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS starts with the default 3D region settings volumes do not work because there is just one level.  
# changing color to constant did not change the color of the isosurface
+
##isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due my resolution being 0.3m, when I change it to 1m I get at least some limited slicing  
 +
###this may be in ogsf becuase slices in nviz do not work with this data either  
 +
#changing color to constant did not change the color of the isosurface
 +
 
 +
[[Sv:Main Page/sv|sv:Main Page/sv]]
 +
 
 +
[[pl:WxNviz/pl|pl:WxNviz/pl]]
  
 
== Google Summer of Code ==
 
== Google Summer of Code ==

Revision as of 15:55, 27 November 2011

Back to wxGUI page.

See also manual page.

wxNviz is a wxGUI extension which allows users to realistically render multiple surfaces (raster data) in a 3D space, optionally using thematic coloring, draping 2D vector data over the surfaces, displaying 3D vector data in the space, and visualization of volume data (3D raster data).

Screenshots

Animations

Using fly-through mode for creating animation

Video tutorials

Loading data, settings layer properties
Visualizing fringes and north arrow
3D raster maps (volumes) in the space (isosurface and slice mode)
Color thematic mapping

Older tutorials (2010)

Loading data, settings layer properties
Visualizing fringes
3D raster maps (volumes) in the space

Ideas

  • Fog support (see [1], [2], [3])
  • Vertical labels (take from geonames.org point data): like in http://tev.fbk.eu/marmota/blog/?p=82
  • Second interactive light source for isosurface visualization
  • Tick marks and coordinate values to x,y,z axis when drawing fringe

Known issues

  1. List of open and closed tickets
  2. Adding vector data crashes wxGUI on Mac
  3. Viewing height sometimes sets to 1 after switching to 2D and back to 3D View (or with the simultaneous 2D view - very nice feature) and even after View is reset, it keeps getting back at 1 each time the slider is touched
    Fixed in r46208
  4. Isosurfaces tested with Nags Head time series data (I will provide link) don't seem to be working, after setting 3D region and adding 3D raster nothing gets drawn, when moving the related DEM around only line rectangle shows instead of a box.
  5. Adding draw, draw current and clear button may be useful
  6. Thematic mapping is available in GRASS 7 only
  7. Display region in 3D does not change accordingly to display region in 2D in version <= 6.5
  8. Appearance:
    1.  I need to click View tab to get the arrow draw, same for the scale bar
    2. add legend > OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D but when I clicked delete scalebar (which was not drawn), my surface disapeared but the legend showed up along with white and black background (which I assume was supposed to be transparent, because when I moved the legend the surface was under it - we already discussed this, it may be my problem, because it works for Michael).
  9. General
    1. when I go from 3D view to 2D and then back to 3D I lose most of my settings (viewing position, zexag, fringe size etc. - this would be OK if I could get a warning and question whether I want to save my 3D viewing state before switching)
    2. similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default
  10. Volumes:
    1. change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS starts with the default 3D region settings volumes do not work because there is just one level.
    2. isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due my resolution being 0.3m, when I change it to 1m I get at least some limited slicing
      1. this may be in ogsf becuase slices in nviz do not work with this data either
  11. changing color to constant did not change the color of the isosurface

sv:Main Page/sv

pl:WxNviz/pl

Google Summer of Code

2008

2010

2011

See also