Difference between revisions of "WxNviz"

From GRASS-Wiki
Jump to: navigation, search
(Known issues)
m (remove hardcoded version specific urls, use latest version)
 
(10 intermediate revisions by 7 users not shown)
Line 1: Line 1:
Back to [[WxPython-based GUI for GRASS|wxGUI]] page.
+
''(Back to [[WxPython-based GUI for GRASS|wxGUI]] page.)''
  
See also {{cmd|wxGUI.Nviz|version=70|desc=manual page}}.
+
'''wxNviz''' is a [[wxGUI]] extension which allows users to realistically render multiple surfaces (raster data) in a 3D space, optionally using thematic coloring, draping 2D vector data over the surfaces, displaying 3D vector data in the space, and visualization of volume data (3D raster data).
 +
 
 +
For usage instructions, see also the {{cmd|wxGUI.nviz|desc=manual page}}.
  
'''wxNviz''' is a [[wxGUI]] extension which allows users to realistically render multiple surfaces (raster data) in a 3D space, optionally using thematic coloring, draping 2D vector data over the surfaces, displaying 3D vector data in the space, and visualization of volume data (3D raster data).
 
 
__TOC__
 
__TOC__
 
== Screenshots ==
 
== Screenshots ==
Line 59: Line 60:
  
 
<strike></strike>  
 
<strike></strike>  
 +
 +
== Troubleshooting  ==
 +
 +
* Nothing is rendered at all:
 +
: Please note that with wxGTK port of wxPython (Linux systems), a problem might appear during wxNviz initialization (nothing is rendered at all) or when rendering vectors (bad order of rendering surfaces and vectors). If you encounter such problems, try to change a depth buffer number in wxGUI Menu > Settings > Preferences > Map Display > Advanced (possible numbers are 0, 16, 24, 32). It is currently not possible to automatically find out the right number which is working for your computer.
  
 
== Known issues  ==
 
== Known issues  ==
Line 66: Line 72:
 
#<strike>Viewing height sometimes sets to 1 after switching to 2D and back to 3D View (or with the simultaneous 2D view - very nice feature) and even after View is reset, it keeps getting back at 1 each time the slider is touched</strike>  
 
#<strike>Viewing height sometimes sets to 1 after switching to 2D and back to 3D View (or with the simultaneous 2D view - very nice feature) and even after View is reset, it keeps getting back at 1 each time the slider is touched</strike>  
 
#:Fixed in {{rev|46208}}  
 
#:Fixed in {{rev|46208}}  
#Isosurfaces tested with Nags Head time series data (I will provide link) don't seem to be working, after setting 3D region and adding 3D raster nothing gets drawn, when moving the related DEM around only line rectangle shows instead of a box.
 
 
#Adding draw, draw current and clear button may be useful  
 
#Adding draw, draw current and clear button may be useful  
 
#Thematic mapping is available in GRASS 7 only  
 
#Thematic mapping is available in GRASS 7 only  
 
#Display region in 3D does not change accordingly to display region in 2D in version &lt;= 6.5  
 
#Display region in 3D does not change accordingly to display region in 2D in version &lt;= 6.5  
 
#Appearance:  
 
#Appearance:  
##&nbsp;I&nbsp;need to click View tab to get the arrow draw, same for the scale bar  
+
##&nbsp;I&nbsp;<strike>need to click View tab to get the arrow draw, same for the scale bar </strike>
 
##add legend &gt; OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D but when I clicked delete scalebar (which was not drawn), my surface disapeared but the legend showed up along with white and black background (which I assume was supposed to be transparent, because when I moved the legend the surface was under it - we already discussed this, it may be my problem, because it works for Michael).  
 
##add legend &gt; OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D but when I clicked delete scalebar (which was not drawn), my surface disapeared but the legend showed up along with white and black background (which I assume was supposed to be transparent, because when I moved the legend the surface was under it - we already discussed this, it may be my problem, because it works for Michael).  
 
#General  
 
#General  
##when I go from 3D view to 2D and then back to 3D I lose most of my settings (viewing position, zexag, fringe size etc. - this would be OK if I could get a warning and question whether I want to save my 3D viewing state before switching)
+
##<strike>when I go from 3D view to 2D and then back to 3D I lose most of my settings&nbsp;</strike>
##similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default  
+
##<strike>similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default </strike>
 
#Volumes:  
 
#Volumes:  
 
##change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS starts with the default 3D region settings volumes do not work because there is just one level.  
 
##change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS starts with the default 3D region settings volumes do not work because there is just one level.  
##isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due my resolution being 0.3m, when I change it to 1m I get at least some limited slicing  
+
##<strike>isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due my resolution being 0.3m, when I change it to 1m I get at least some limited slicing  
###this may be in ogsf becuase slices in nviz do not work with this data either  
+
###this may be in ogsf becuase slices in nviz do not work with this data either </strike>
#changing color to constant did not change the color of the isosurface
+
#<strike>changing color to constant did not change the color of the isosurface</strike>
  
[[Sv:Main Page/sv|sv:Main Page/sv]]
+
== Comparison of Tcl/Tk nviz and wxNviz functionality ==
 +
What is missing in wxNviz:
 +
* scaled difference
 +
* lighting - follow surface viewpoint
 +
* keyframe animation
 +
* text rendering (in OpenGl)
 +
 
 +
What is working only partially:
 +
* legend, labels
 +
* thematic mapping - nviz allows to choose also icon and multiple classification
 +
* basic support of animations
 +
 
 +
What is new in wxNviz:
 +
* it is possible to change view more interactively using mouse
 +
 
 +
Notes:
 +
* Scripting functionality is replaced by m.nviz.image module
 +
* wxNviz state is saved in workspace
  
[[pl:WxNviz/pl|pl:WxNviz/pl]]
 
  
 
== Google Summer of Code ==
 
== Google Summer of Code ==
Line 105: Line 126:
  
 
{{WxGUI}}
 
{{WxGUI}}
 +
 +
[[Category:NVIZ]]
 +
[[Category:Visualization]]

Latest revision as of 03:56, 4 December 2018

(Back to wxGUI page.)

wxNviz is a wxGUI extension which allows users to realistically render multiple surfaces (raster data) in a 3D space, optionally using thematic coloring, draping 2D vector data over the surfaces, displaying 3D vector data in the space, and visualization of volume data (3D raster data).

For usage instructions, see also the manual page.

Screenshots

Animations

Using fly-through mode for creating animation

Video tutorials

Loading data, settings layer properties
Visualizing fringes and north arrow
3D raster maps (volumes) in the space (isosurface and slice mode)
Color thematic mapping

Older tutorials (2010)

Loading data, settings layer properties
Visualizing fringes
3D raster maps (volumes) in the space

Ideas

  • Fog support (see [1], [2], [3])
  • Vertical labels (take from geonames.org point data): like in http://tev.fbk.eu/marmota/blog/?p=82
  • Second interactive light source for isosurface visualization
  • Tick marks and coordinate values to x,y,z axis when drawing fringe

Troubleshooting

  • Nothing is rendered at all:
Please note that with wxGTK port of wxPython (Linux systems), a problem might appear during wxNviz initialization (nothing is rendered at all) or when rendering vectors (bad order of rendering surfaces and vectors). If you encounter such problems, try to change a depth buffer number in wxGUI Menu > Settings > Preferences > Map Display > Advanced (possible numbers are 0, 16, 24, 32). It is currently not possible to automatically find out the right number which is working for your computer.

Known issues

  1. List of open and closed tickets
  2. Adding vector data crashes wxGUI on Mac
  3. Viewing height sometimes sets to 1 after switching to 2D and back to 3D View (or with the simultaneous 2D view - very nice feature) and even after View is reset, it keeps getting back at 1 each time the slider is touched
    Fixed in r46208
  4. Adding draw, draw current and clear button may be useful
  5. Thematic mapping is available in GRASS 7 only
  6. Display region in 3D does not change accordingly to display region in 2D in version <= 6.5
  7. Appearance:
    1.  I need to click View tab to get the arrow draw, same for the scale bar
    2. add legend > OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D but when I clicked delete scalebar (which was not drawn), my surface disapeared but the legend showed up along with white and black background (which I assume was supposed to be transparent, because when I moved the legend the surface was under it - we already discussed this, it may be my problem, because it works for Michael).
  8. General
    1. when I go from 3D view to 2D and then back to 3D I lose most of my settings 
    2. similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default
  9. Volumes:
    1. change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS starts with the default 3D region settings volumes do not work because there is just one level.
    2. isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due my resolution being 0.3m, when I change it to 1m I get at least some limited slicing
      1. this may be in ogsf becuase slices in nviz do not work with this data either
  10. changing color to constant did not change the color of the isosurface

Comparison of Tcl/Tk nviz and wxNviz functionality

What is missing in wxNviz:

  • scaled difference
  • lighting - follow surface viewpoint
  • keyframe animation
  • text rendering (in OpenGl)

What is working only partially:

  • legend, labels
  • thematic mapping - nviz allows to choose also icon and multiple classification
  • basic support of animations

What is new in wxNviz:

  • it is possible to change view more interactively using mouse

Notes:

  • Scripting functionality is replaced by m.nviz.image module
  • wxNviz state is saved in workspace


Google Summer of Code

2008

2010

2011

See also